Results 1 to 5 of 5

Thread: reCaptcha 2.0 doesn't work (but 1.0 works fine)

  1. #1
    JTCB is offline Junior Member
    Join Date
    Jul 2015
    Posts
    11

    Default reCaptcha 2.0 doesn't work (but 1.0 works fine)

    Hi

    I have a problem in making reCaptcha 2.0 work on my live website.

    It works fine on the localhost but when I am trying to use it on the live website on AlterVista it just loops.

    I use it for contact form. Whenever I try to fill the form for a test, then solve the reCaptcha 2.0 and click "send email"
    The page simply refreshes with all the form filled again and I can keep doing that over and over but nothing really gets through.

    I am on Joomla 3.4.3. Using built-in reCaptcha plugin. It works fine if I switch to 1.0 but won't work when on 2.0.
    My keys are 3 days old, they are 2.0 keys and I have already tried deleting the keys and getting new ones, which didn't help.

    I asked around and some people said I should try enabling:
    allow_url_fopen

    on my server... I tried doing that by adding:
    php_value allow_url_fopen On

    to .htaccess
    but that didn't help either.

    Some of the people I asked pointed out that this might be an issue on my hosting so I'm posting this thread here.
    Maybe something is wrong like on the whitelist or some other php setting that is breaking that reCaptcha 2.0?

    Any help is appreciated.

    ---
    A friend gave me this advice, after one 3rd party extension made captcha to work somehow.

    He wrote this:
    "It would appear that your server has CURL enabled but has allow_url_fopen set to Off. This cannot be enabled by a simply ini_set() function so unless you have access to your php.ini file to change it, you're going to have to either ask your hosting provider to enable it or stick with the other extension you're using"

    So, who should I contact here to get this allow_url_fopen to be set on?
    Last edited by JTCB; 09-04-2015 at 10:12 PM.

  2. #2
    karl94 is offline AlterVista Staff
    Join Date
    Jan 2015
    Posts
    573

    Default

    You have to unlock the server to server connections, go in the AlterVista control panel, Resources section then Edit PHP Settings. You'll find the server to server connections settings at the bottom of the page.

  3. #3
    JTCB is offline Junior Member
    Join Date
    Jul 2015
    Posts
    11

    Default

    Thank you for your response. But aren't things like google already white-listed and shouldn't it work out of the box?

  4. #4
    karl94 is offline AlterVista Staff
    Join Date
    Jan 2015
    Posts
    573

    Default

    You are right, it should work even with the whitelist active. I fixed a file on your Joomla installation, could you please try now?

  5. #5
    JTCB is offline Junior Member
    Join Date
    Jul 2015
    Posts
    11

    Default

    Sorry, that didn't work for me. Which file were you trying to modify if I may know by the way?

    I guess it's ok. Perhaps it's some kind of limitation?
    I have switched from the built-in plugin to something a friend cooked up, an extension that takes into account curl and fopen being set differently.
    So I guess it will do for me.

    I don't really have a need to use built-in joomla's plugin when a 3rd party does the job in the current environment.

    So yeah, let's just bring the file back to how it was and I will continue setting my page.
    Thanks again for the help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO