Results 1 to 10 of 10

Thread: Shortcode not update

  1. #1
    meteopsiria is offline Utente AlterBlog
    Join Date
    Oct 2018
    Posts
    11

    Default Shortcode not update

    Good night,

    After installing the weather station plugin for wordpress and ordering from server to server I was able to connect my netatmo station to the plugin.

    Then something strange happens this plugin allows to show, graphics and animations that are updated in a page with shortcode, happens that the station updates every 5 minutes, but after some time the graphs of temperature, humidity etc stop updating automatically, if make a reload of the page of the same, after some time it acts again.

    What is up?

  2. #2
    alemoppo is offline AlterVista Staff
    Join Date
    Feb 2010
    Location
    IT
    Posts
    182

    Default

    Probably it is the cache.
    You should try deleting your browser cache, or using a different browser.
    Probably there are also plugins to force the loading of the new image.

    Bye!

  3. #3
    meteopsiria is offline Utente AlterBlog
    Join Date
    Oct 2018
    Posts
    11

    Default

    Good Morning,

    First of all, I would like to thank you for your help! I have continued the tests and what I have observed, is that shortcodes only update if the page is open and wordpress is logged in!

    This plugin allows you to make a collection of data and present them through graphs, example of a graph of mine and example of another site.


    https://imgur.com/a/oxgyrdA
    https://imgur.com/EpVtVvk

    basically what happens is that my updates every visit and the other every 10 minutes. Is there any way around this?

  4. #4
    alemoppo is offline AlterVista Staff
    Join Date
    Feb 2010
    Location
    IT
    Posts
    182

    Default

    I think you should ask the plugin developer, it seems like a plugin problem.

    Bye!

  5. #5
    meteopsiria is offline Utente AlterBlog
    Join Date
    Oct 2018
    Posts
    11

    Default

    Good afternoon,
    I already contacted the plugin developer and he told me that the problem is in the wordpress cronjobs.

    Is there a way around this?

  6. #6
    alemoppo is offline AlterVista Staff
    Join Date
    Feb 2010
    Location
    IT
    Posts
    182

    Default

    It's strange that this plugin require cron job.
    I don't know how the weather station and the plugin work, but at every request of the weather station, the plugin should save the data. I don't understand about the user's visits.

    Bye!

  7. #7
    meteopsiria is offline Utente AlterBlog
    Join Date
    Oct 2018
    Posts
    11

    Default

    Good Morning,

    therefore, what I was told is that it works with cronjobs and normally all plugins have this problem with wordpress.

    Here is the topic.

    Is there no way to solve this? the plugin works through the netatmo api, then begins to give errors of the type of the photos.

    Basically this is if you have traffic the plugin works, if it is not being visited for about eight hours, it only refreshes again when there are traffic / visitors again.

    https://imgur.com/a/RQ19Knx

  8. #8
    alemoppo is offline AlterVista Staff
    Join Date
    Feb 2010
    Location
    IT
    Posts
    182

    Default

    Did you try using cron-job.org?

    You can't disable wordPress cron.

    Bye!

  9. #9
    meteopsiria is offline Utente AlterBlog
    Join Date
    Oct 2018
    Posts
    11

    Default

    Quote Originally Posted by alemoppo View Post
    Did you try using cron-job.org?

    You can't disable wordPress cron.

    Bye!
    Good Morning,

    I know I can not disable wordpress cron, but you can.
    Of course as soon as I tried to use cron-job.org it gives successive errors because it was necessary to disable wordpress ...

    The errors are all the same "Response data too big"

    This is just one of them:
    Date: Wed, 07 Nov 2018 22:55:34 GMT
    Server: Apache
    AV-Custom-Post-Type: page
    Link: <http://meteopsiria.altervista.org/wp-json/>; rel="https://api.w.org/"
    Link: <http://meteopsiria.altervista.org/>; rel=shortlink
    Vary: Accept-Encoding
    Content-Type: text/html; charset=UTF-8
    X-Varnish: 457504271 461668744
    Age: 1204
    Via: 1.1 varnish (Varnish/5.1)
    WPVarnish-Cache: HIT:4
    Accept-Ranges: bytes

  10. #10
    alemoppo is offline AlterVista Staff
    Join Date
    Feb 2010
    Location
    IT
    Posts
    182

    Default

    Hello, if the answer is too long is not a problem: the script will still be executed correctly.

    But the answer to the request is not Apache, but it is of the cache (varnish), so actually the request does not arrive up to the server but it stops first, in the cache.
    Try then disabling the altervista cache (settings -> Altervista Cache).

    Bye!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO