Results 1 to 7 of 7
Like Tree2Likes
  • 1 Post By alemoppo
  • 1 Post By alemoppo

Thread: Multilanguage issue, mixed languages

  1. #1
    kgb
    kgb is offline Junior Member
    Join Date
    Jan 2018
    Location
    Belgrade
    Posts
    8

    Default Multilanguage issue, mixed languages

    Hi guys, if you don't mind a little help please:

    A friend had helped me sign up (some scripting issue on localhost) and he had used the Italian version... My email and data and everything. So, when I logged in - I changed the language to English (US), BUT some of the interface components, plugin descriptions and certain sections remain in ITALIAN.

    Have we gone about this the wrong way, would there be no such issue if I signed up from:
    Code:
    https://en.altervista.org/
    ... Or, are the default templates in the server setup still language-mixed (I know that sometimes this can happen, even when the localization separation is strictly adhered to).

    What am I to do, re-signup?! Not sure what I'll be able to do with my current address, in this case... And, I mean, I don't even know whether the English version will still have those Italian sections. :-/

    Thanks for any info!!

    P.S.
    When I went to post this, even though I had been logged in - I was redirected to a NON-SSL page, where it's asking me to login again:
    Code:
    http://forum.en.altervista.org/newthread.php?do=postthread&f=11
    This is a localhost (browser scripting and cookie) issue, but my guess is that it still shouldn't happen... Oh and after entering the data, still not logged in. Trying to post the topic again, not sure whether it'll work or not.

    EDIT: Managed to post it (obviously, hehe), looks like there are several different cookies and paths involved (quite possibly because the forums and the blogs are sharing the login info; because of the forums plugin.)

    EDIT: Alright, here's the message... Seems like the certificate used isn't the latest and the greatest (and so my Firefox is set-up to deny those connections):

    Secure Connection Failed

    An error occurred during a connection to forum.en.altervista.org. Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP
    (Btw., rest of the Internet functions just fine with this setup - it's only certain web sites, with certain certs.)
    Last edited by kgb; 02-01-2018 at 05:47 PM.

  2. #2
    alemoppo is offline AlterVista Staff
    Join Date
    Feb 2010
    Location
    IT
    Posts
    286

    Default

    Hi, you can change language from the settings page: http://kgb.altervista.org/wp-admin/options-general.php Where you changed the language?
    The default article still in italian but you should delete it and write your articles.

    Bye!
    kgb likes this.

  3. #3
    kgb
    kgb is offline Junior Member
    Join Date
    Jan 2018
    Location
    Belgrade
    Posts
    8

    Default

    Quote Originally Posted by alemoppo View Post
    Code:
    http://kgb.altervista.org/wp-admin/options-general.php
    Yup, thanks!.. That is where I had changed it from:



    And, then, here's one example of content which remains in Italian:



    ... However, this is trivial; I'm looking for another, pretty sure there were more (otherwise I could be wasting your time here, heh.:))

  4. #4
    kgb
    kgb is offline Junior Member
    Join Date
    Jan 2018
    Location
    Belgrade
    Posts
    8

    Lightbulb

    Here are three more pages, Dashboard: Update blog, Statistics, Domains @
    Code:
    https://postimg.org/gallery/daite7x8/
    Edit: Again, not such a big deal (at all); but, it raises a bit of a question: whether there are any more, such, misconfigurations (again, even though this is trivial and, really, a non-issue.)

    Edit: You know, after reviewing everything again... It seems like I might've been too quick to post! :( It looks as though everything should be normal, right?!??

    (I suppose we can close this, as solved, unless you may think otherwise. Thank you for your reply!..:))
    Last edited by kgb; 02-01-2018 at 09:53 PM.

  5. #5
    alemoppo is offline AlterVista Staff
    Join Date
    Feb 2010
    Location
    IT
    Posts
    286

    Default

    Ok, but if you want all in english, you should register from international site: https://en.altervista.org

    The demo comment, title and tagline like demo article are in Italian but you should have to modify/delete them.


    Bye!
    kgb likes this.

  6. #6
    kgb
    kgb is offline Junior Member
    Join Date
    Jan 2018
    Location
    Belgrade
    Posts
    8

    Default

    Quote Originally Posted by alemoppo View Post
    Ok, but if you want all in english, you should register from international site: https://en.altervista.org
    Ultimately, that would be the issue that I'm faced with! :( Since I've already made a blog URL (address), it would be impossible for me to get that same blog address, but with: https://en.altervista.org

  7. #7
    alemoppo is offline AlterVista Staff
    Join Date
    Feb 2010
    Location
    IT
    Posts
    286

    Default

    Try:
    • Users
    • Altervista Data
    • Lingua: select "English" (see below image)
    • Click on "Cambia dati" (see below image)



    This should fix Update blog, Statistics, Domains pages.

    If you want register from international site, you have to delete your account: http://en.altervista.org/delete.php (it may require 7 days!)

    Bye!
    Last edited by alemoppo; 02-02-2018 at 08:52 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO